Having problems with your order?
We invite you to contact customer service.

If you are using an older browser, your issues may be related to recent updates that have affected certain users on older browsers.

Why does your site suddenly not work for me?
There can be many reasons, but if you are suddenly having problems, it is likely due to recent industry regulation changes that all sites that process credit cards will have to respect in order to offer a secure online store experience.

When you log in or interact with any of our secure pages, your browser takes your information and encrypts it in into a secure string of characters and letters, so that hackers who want to steal your data cannot.

Older browsers relied upon the old industry standard (TLS 1.0). Over time, this level of security has grown less and less secure, forcing the industry to upgrade to newer and more secure standards (TLS 1.1, and 1.2).

As much as it may cause inconvenience for our customers, and as much as it may hurt, we can never, ever afford to compromise on the security of our customers’ data.

What should I do now?
You should upgrade your browser. You may be having trouble only with our site today, but you will need to upgrade soon to avoid problems globally, as everyone will be changing over to the new encryption systems in early 2016 if they have not already.

Please refer to the chart below in order to find help and instructions for common browsers:

Google Chrome (Windows)
Minimum: Version 32 or newer is compatible in most cases, some exceptions may apply
Recommended: Version 38 or newer
Link to update instructions here: https://support.google.com/chrome/answer/95414?hl=en

For versions 32 - 40, you need to manually enable support for TLS v1.1 and 1.2. Follow the instructions below to do this:

  1. Open your Chrome Browser
  2. Click on the drop sown menu, or press ALT-F on your keyboard and select "Settings"
  3. At the bottom of the page, click on "Show Advanced Settings..."
  4. Scroll down to the "Network" section and click "Change proxy settings..."
  5. Next, select the "Advanced" tab
  6. Scroll down to the "Security" section
  7. Locate and mark the "Use TLS 1.1 and TLS 1.2" checkbox


Google Chrome (Android)
Minimum:  Android 4.4 or newer recommended, may require additional configuration to activate newer encryption on devices.
Recommended: Android 5.0
Link to update instructions here: https://support.google.com/chrome/answer/95414?hl=en

Mozilla Firefox
Minimum: Version 23 -26 compatible with additional configuration.
Configuration instructions here: https://defuse.ca/blog/enabling-tls-11-on-firefox-version-23.html
Recommended: Version 27  
Link to update instructions here: https://support.mozilla.org/en-US/kb/update-firefox-latest-version

Internet Explorer
Minimum: Version 8,9,10 compatible (*Computers running Windows XP not compatible), but may need additional configuration
Recommended: Explorer 11 or Edge–it is recommended that all users upgrade to edge
Information on Internet Explorer and upgrade information here: http://windows.microsoft.com/en-us/internet-explorer/which-version-am-i-using#ie=other

For users on Internet Explorer 8-10, you need to manually enable support for TLS v1.1 and 1.2. Follow the instructions below to do this:

  1. Open your Internet Explorer Browser
  2. Open Internet Options
  3. Click on the Advanced Tab
  4. Scroll down to the Security Section
  5. Select Use TLS 1.1 and Use TLS 1.2



Opera Browser
Recommended: Versions 27 and up

Safari OSX (desktop)
Recommended: Version 9 or better (requires OSX 10.9)

Safari Mobile
Recommended: Version 5 or better.